Connectivity issues

Incident
06 October 2020, 19:00 UTC

Connectivity issues

Status: closed
Start: 06 October 2020, 08:10 UTC
End: 06 October 2020, 19:00 UTC
Duration: 10 hours 49 minutes
Affected Components:
London San Francisco
Investigating

06 October 2020, 08:10 UTC

06 October 2020, 08:10 UTC

We are experiencing severe connectivity problems right now, possibly due to high load. Originally this started in the London region. Failover to other regions was initiated, but this caused SF to fail. We are still investigating the cause.

Investigating

06 October 2020, 12:49 UTC

06 October 2020, 12:49 UTC

Service has stabilized. Some accounts may be getting rate limited.

Resolved

06 October 2020, 19:00 UTC

06 October 2020, 19:00 UTC

We determined the problem to be an unexpectedly large amount of traffic near our London region. It defeated our rate limiting by overwhelming our load balancers. In the future we will aim to have far more load balancer capacity than is necessary during normal conditions, to ensure high traffic from one customer doesn't take us down.