Performance Issues Impacting Compute@Edge Purging

Incident
24 May 2023, 01:34 UTC

Performance Issues Impacting Compute@Edge Purging

Status: closed
Start: 23 May 2023, 22:42 UTC
End: 24 May 2023, 01:34 UTC
Duration: 2 hours 52 minutes
Affected Components:
Compute Compute@Edge
Investigating

23 May 2023, 22:42 UTC

23 May 2023, 22:42 UTC

We're investigating issues affecting purging for Compute@Edge services.

Identified

23 May 2023, 23:23 UTC

23 May 2023, 23:23 UTC

This issue has been identified and a fix is being implemented. 

Identified

24 May 2023, 00:13 UTC

24 May 2023, 00:13 UTC

Engineering has applied a fix to Compute@Edge Purging. After further investigation we are deploying additional mitigation strategy.

Monitoring

24 May 2023, 01:07 UTC

24 May 2023, 01:07 UTC

A fix has been implemented and we are monitoring the results.

Resolved

24 May 2023, 01:34 UTC

24 May 2023, 01:34 UTC

This incident has been resolved.