Retrospective: Fastly Next-Gen WAF Performance Issues

Incident
20 June 2023, 22:24 UTC

Retrospective: Fastly Next-Gen WAF Performance Issues

Status: closed
Start: 20 June 2023, 20:29 UTC
End: 20 June 2023, 22:24 UTC
Duration: 1 hour 55 minutes
Affected Components:
Security NGWAF@Edge
Monitoring

20 June 2023, 20:29 UTC

20 June 2023, 20:29 UTC

Fastly Engineering detected an event resulting in missing data affecting Next-Gen WAF during the following time frames on June 20, 2023:

  • 20:29 - 20:33 UTC
  • 20:55 - 20:58 UTC
  • 21:21 - 21:25 UTC
  • 22:20 - 22:24 UTC

All other services were unaffected.


Resolved

20 June 2023, 22:24 UTC

20 June 2023, 22:24 UTC

The issue has been resolved and we are monitoring performance closely.