Retrospective: Fastly Application and API Performance Issues

Incident
26 June 2023, 21:53 UTC

Retrospective: Fastly Application and API Performance Issues

Status: closed
Start: 26 June 2023, 21:23 UTC
End: 26 June 2023, 21:53 UTC
Duration: 30 minutes
Affected Components:
Compute API & Configuration Management Configuration Deployment Fastly Application Fastly API
Monitoring

26 June 2023, 21:23 UTC

26 June 2023, 21:23 UTC

Fastly Engineers detected a performance impacting event affecting the availability of manage.fastly.com and API.

CDN delivery, stats aggregation, and all other data plane services were unaffected.

The issue has been resolved and we are monitoring performance closely.

Resolved

26 June 2023, 21:53 UTC

26 June 2023, 21:53 UTC

This incident is resolved.

Customers may have experienced elevated errors or timeouts when attempting to access the Fastly API and our Control Plane (manage.fastly.com) from 20:56 to 21:10 UTC. 

All other services were unaffected.