Possible Performance Impact to NGWAF@Edge Services

Incident
15 July 2023, 13:22 UTC

Possible Performance Impact to NGWAF@Edge Services

Status: closed
Start: 14 July 2023, 06:13 UTC
End: 15 July 2023, 13:22 UTC
Duration: 1 day 7 hours 9 minutes
Affected Components:
Security NGWAF@Edge
Identified

14 July 2023, 06:13 UTC

14 July 2023, 06:13 UTC

Incident identified on the 14th of July 2023 at 06:13 UTC.

Fastly Engineering has identified a performance impacting event to our NGWAF@Edge services.

Customers may experience delays detecting clients exceeding the threshold set in rate limit rules/site alerts and loading dashboard data for NGWAF services within our console.

Existing NGWAF@Edge rules and all other platform services are unaffected.

Monitoring

14 July 2023, 07:05 UTC

14 July 2023, 07:05 UTC

A fix has been implemented and we are monitoring the results.

Identified

14 July 2023, 20:59 UTC

14 July 2023, 20:59 UTC

Fastly Engineering has identified an additional performance impacting event to our NGWAF@Edge services.

Customers may experience delays detecting clients exceeding the threshold set in rate limit rules/site alerts and loading dashboard data for NGWAF services within our console.

Existing NGWAF@Edge rules and all other platform services are unaffected.

The issue has been identified and we are preparing an additional fix. 

Monitoring

14 July 2023, 22:32 UTC

14 July 2023, 22:32 UTC

A fix has been implemented and we are monitoring the results.

Resolved

15 July 2023, 13:22 UTC

15 July 2023, 13:22 UTC

This incident has been resolved.