Fastly API Performance Issues

Incident
18 July 2023, 04:31 UTC

Fastly API Performance Issues

Status: closed
Start: 18 July 2023, 03:28 UTC
End: 18 July 2023, 04:31 UTC
Duration: 1 hour 3 minutes
Affected Components:
Compute API & Configuration Management Fastly API
Investigating

18 July 2023, 03:28 UTC

18 July 2023, 03:28 UTC

We are currently investigating performance issues affecting the availability of our API. CDN delivery, stats aggregation, and all other data plane services are unaffected.

Identified

18 July 2023, 03:37 UTC

18 July 2023, 03:37 UTC

This issue has been identified and a fix is being implemented. 

Monitoring

18 July 2023, 04:15 UTC

18 July 2023, 04:15 UTC

A fix has been implemented and we are monitoring the results.

Resolved

18 July 2023, 04:31 UTC

18 July 2023, 04:31 UTC

This incident has been resolved.