Fastly Control Plane Performance Issues

Incident
07 August 2023, 20:16 UTC

Fastly Control Plane Performance Issues

Status: closed
Start: 07 August 2023, 18:26 UTC
End: 07 August 2023, 20:16 UTC
Duration: 1 hour 50 minutes
Affected Components:
Compute API & Configuration Management Configuration Deployment Fastly Application Fastly API
Investigating

07 August 2023, 18:26 UTC

07 August 2023, 18:26 UTC

We are currently investigating performance issues affecting the availability of manage.fastly.com and our API. CDN delivery, stats aggregation, and all other data plane services are unaffected.

Update

07 August 2023, 18:51 UTC

07 August 2023, 18:51 UTC

We are continuing to investigate performance issues affecting the availability of manage.fastly.com and our API. CDN delivery, stats aggregation, and all other data plane services are unaffected.


Identified

07 August 2023, 19:39 UTC

07 August 2023, 19:39 UTC

This issue has been identified and a fix is being implemented. 

Monitoring

07 August 2023, 19:59 UTC

07 August 2023, 19:59 UTC

A fix has been implemented and we are monitoring the results.

Resolved

07 August 2023, 20:16 UTC

07 August 2023, 20:16 UTC

This incident has been resolved.